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Preface

This document supports the MPEG Video Stream Analyzer application.

If you purchased an MTS 300 Series test system and are looking for information
about installation, first-time operation, or specifications, refer to the MTS 300
MPEG Test System Hardware and Software Installation Technical Reference,
Tektronix part number 071-0667-XX.

For the latest information about MTS 300 Series software features and bugs,
refer to the MPEG Test System Software Version 5.0 Read This First document,
Tektronix part number 071-0666-XX, that accompanied your test system,
software product, or upgrade.

Table i lists the MTS 300 Series MPEG Test System application version
supported by this manual. To verify an application version number, select Help
in the application menu bar; then select About from the Help menu.

Table i: MTS 300 Series MPEG Test System (V5.0) supported applications 

Application Supported version

MPEG-2 Video Stream Analyzer V1.03 and above
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Contacting Tektronix

Product
Support

For questions about using Tektronix measurement products, call
toll free in North America:
1-800-833-9200
6:00 a.m. – 5:00 p.m. Pacific time

Or contact us by e-mail:
tm_app_supp@tek.com

For product support outside of North America, contact your
local Tektronix distributor or sales office.

Service
support

Tektronix offers a range of services, including Extended
Warranty Repair and Calibration services. Contact your local
Tektronix distributor or sales office for details.

For a listing of worldwide service centers, visit our web site.

Toll-free
Number

In North America:
1-800-833-9200
An operator can direct your call.

Postal 
Address

Tektronix, Inc.
Department or name (if known)
P.O. Box 500
Beaverton, OR 97077
USA

Web site www.tektronix.com
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Getting Started

Product Description
You can use the MPEG Video Stream Analyzer to analyze and save MPEG-1 and
MPEG-2 video elementary streams. You can display MPEG video elementary
stream structures, items, and parameters at different levels using a variety of
secondary windows called view windows.

The following view windows provide high-level views of the video stream:

� Main Characteristics (see page 2–7)

� Main (see page 2–8)

� Decoded Picture (see page 2–11)

The following four view windows, called interpreted views, provide graphical
displays of the video stream syntax:

� Sequence (see page 3–4)

� Group of pictures (GOP) (see page 3–5)

� Pictures (see page 3–6)

� Slice (see page 3–8)

All of the interpreted views are interactive in ways that make it easy for you to
analyze the structures of the elementary stream.

Finally, you can view the bitstream of the video elementary stream in binary and
hexadecimal formats using the Binary or Hexadecimal view windows.

From the Interpreted, Binary, and Hexadecimal view windows, you can perform
a syntactic analysis of the active MPEG structure. From the Main and Decoded
Picture view windows you can also perform a semantic analysis on the complete
video stream. See Analyzing Video Elementary Streams on page 2–17 and
Analyzing Video Elementary Streams on page 3–11 for more information on
performing syntactic and semantic analyses.

View Windows

Analyses
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The MPEG Video Stream Analyzer does not perform a syntactic analysis on the
following MPEG-2 structures:

� Macroblock

� Macroblock modes

� Motion vectors

� Motion vector

� Coded block pattern

� Block

First Time Operation
The MPEG Video Stream Analyzer is part of a suite of hardware and software
components used to create, generate, acquire, and analyze MPEG and DVB
transport and program streams. Before you can use the analyzer, you need to
ensure that you have entered the correct password for your software configura-
tion. To enable the test system configuration you have purchased, use the
procedure for entering the general password described in the MPEG Test System
Software MTS2ES, MTS2AN, MTS2CR, and MTS2TS Installation Manual.

NOTE. If you have already performed the procedure described in the installation
manual, you do not need to perform it again.

Limitations
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Operating Basics

Operating Basics is organized into the following sections:

� Starting the MPEG Video Stream Analyzer describes how to start the
analyzer using standard Windows NT techniques.

� Functional Overview describes the application window types and the
application interface elements.

� MPEG Video Stream Analyzer Views describes the views used by the
application and how to access them.

� Basic Operations describes common procedures used to display, analyze,
and decode video stream files.

� Menu Selections summarizes the menu selections.

NOTE. For basic Windows operating techniques such as, minimizing windows or
using the scroll bars, refer to your Windows documentation.

Starting the MPEG Video Stream Analyzer

Double-click the MPEG Video Stream Analyzer icon in the MPEG Test
System program group window.
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Functional Overview
The MPEG Video Stream Analyzer uses two window types to display video
elementary streams: an application window and secondary windows called view
windows. Functional Overview describes the characteristics of these windows.

When you first open a video elementary stream, the application window opens
and looks similar to the following illustration.

TItle bar
Menu bar

Upper toolbar

Status bar

Edit toolbar

The following sections describe the elements of the application window.

Title Bar. The title bar displays the application name and icon. The window
control buttons allow you to minimize, maximize, and close the application
window.

Application Window
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Menu Bar. The menu bar provides access to the commands you use to control the
display, analysis, and look of the MPEG Video Stream Analyzer. A list of menu
selections is provided in Menu Selections beginning on page 2–19.

Upper Toolbar. The Upper toolbar provides shortcut buttons to five commonly
used menu selections. These buttons, and the menu selections they represent, are
described in Table 2–1.

Table 2–1: Upper toolbar buttons 

Button Name Description

Open Displays the Open dialog box. Selecting this button is the
same as selecting Open from the File menu (see
page 2–13).

Save as Displays the Save As dialog box. Selecting this button is the
same as selecting Save As from the File menu (see
page 2–15)

Main view Displays the Main view window for the active video stream.
Selecting this button is the same as selecting Main view
from the Selection menu (see page 2–8).

Add view Displays a submenu from which you specify a view to be
displayed. Selecting this button is the same as selecting
Add view from the Window menu (see page 2–12).

Main characteristics
view

Displays the Main Characteristics window for the active
video stream. Selecting this button is the same as selecting
Main characteristics from the Selection menu (see
page 2–7).
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Edit Toolbar. The Edit toolbar provides shortcut buttons to selections found in the
Edit menu. These buttons, described in Table 2–2, allow you to move through
the items (decoded picture, sequence, GOP, or picture items) of the active view
and to view the errors in the video stream file. More complete descriptions of
these buttons are provided in the Menu Selections section beginning on
page 2–19 where the Edit Menu selections are described. (The button descrip-
tions are the same as the menu selection descriptions.)

Table 2–2: Edit toolbar buttons 

Button Name Description

First Displays the first item in the active view. Selecting this button is
the same as selecting First from the Edit menu.

Previous Displays the previous item in the active view. Selecting this
button is the same as selecting Previous from the Edit menu.

Go to Displays a dialog box that allows you to select the item number
of the active view you want displayed. Selecting this button is
the same as selecting Go to from the Edit menu.

Next Displays the next item in the active view. Selecting this button is
the same as selecting Next from the Edit menu.

Last Displays the last item in the active view. Selecting this button is
the same as selecting Last from the Edit menu.

Number of Items Counts the number of items in the element and displays the
number at the top of the interpreted view. Selecting this button is
the same as selecting Number of Items from the Edit menu.

Next error Displays the next item that has an error in the video stream file.
Selecting this button is the same as selecting Next error from
the Edit menu.

Status Bar. The Status bar, located just below the Edit toolbar, provides you with
first level help on using the menus. As you highlight a menu item, the status bar
describes the menu selection.
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View windows display the syntax of the elementary stream at different levels.
The following illustration shows the Main view window and the application
window.

Application
window

View
window

Common View Window Elements. In addition to standard window controls, the
title bar of the view windows provides the following information:

� View type. The view type indicates the type of view displayed in the view
window.

� File name. The file name indicates the name of the video stream file or the
transport stream from which the video stream was extracted.

NOTE. If you maximize the view window, the view type and file name are
displayed in the title bar of the application window.

View Windows
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The top line of the Main and interpreted view windows provides the following
information (refer to the illustration below):

� View type. The view type indicates the type of view displayed (Main,
Sequence, GOP, or Picture).

� Item. The item indicates which item of the viewed syntax is displayed. From
the Main view window, you can display the total number of items in each
structure by performing one of the following operations:

� Click the Number of Items command button from the Edit toolbar (see
page 2–4).

� Select Number of Items from the Edit menu. 

The Number of Items message window is then displayed, indicating the total
number of Sequences and GOPs in that structure for the active video stream.

The total number of items in each structure is displayed in the top line of the
view window as shown in the following illustration.

In the interpreted views, the item number provided is the number of items in
the displayed structure. For instance, if you were to double-click the GOP
rectangle, the top line of the GOP interpreted view window would look
similar to the following illustration.
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The areas of the view windows below the top line are described briefly in the
next section, MPEG Video Stream Analyzer Views. They are described more
thoroughly in the Reference section of this manual.

MPEG Video Stream Analyzer Views
You can use the MPEG Video Stream Analyzer to view elementary video
streams at different levels. This section briefly describes these views and how to
access them. See Interpreted Views beginning on page 2–9, and see Additional
Views beginning on page 3–9 for more detailed information about the various
view types used by the analyzer.

When you open a new video elementary stream, the Main Characteristics view
window is automatically displayed if the elementary stream includes a sequence
header.

NOTE. Because the main characteristics of the stream are read in the first
sequence header of the stream, if the stream does not contain a sequence header,
the Main Characteristics view window is not displayed and is not available from
any other view window. The requirement for a sequence header also means that
if a video stream is opened as a Sequence, GOP, or Picture document file type
(see Opening Video Streams, on page 2–13), the Main Characteristics view
window will not be available.

The Main Characteristics view window allows you to quickly access basic
information about the video stream.

Main Characteristics View
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Display the Main Characteristics view window from any of the other view
windows by clicking the Main Characteristics button on the Upper toolbar (see
page 2–3), or by selecting Main Characteristics from the Selection menu.

When you open a video elementary stream as a Video Stream file type (see
Opening Video Streams on page 2–13), the Main view window is displayed. The
Main view is interactive and allows you to display specific video stream syntax
for further analysis.

NOTE. To display the Main view window, the video stream must include a
sequence header. You can open a video stream that does not have a sequence
header by opening the file as a Sequence, GOP, or Picture document. See
Opening Video Streams on page 2–13.

Display the Main view window from any of the other interpreted view windows
by clicking the Main View button on the Upper toolbar (see page 2–3), or by
selecting Main View from the Selection menu.

The different elements of the displayed video stream are represented by
rectangles. Each rectangle displays some minimal information about the
structures of a sequence, GOP or picture. For example, in the illustration above,
the sequence structure consists of a sequence header, sequence extension, and
user data.

Table 2–3 lists the video stream elements displayed in the Main view window.
Double-click the rectangles to access more detailed interpreted views for the
structures indicated. (The page numbers in parentheses indicate where the
interpreted view for each structure is discussed in this manual.)

Main View
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Table 2–3: Main view elements 

Element rectangle Video stream element

Sequence (page 3–4)

GOP (page 3–5)

Picture (page 3–6)

The gray title bar in the Picture rectangles indicates the picture number, coding
type (I, P or B), structure (field or frame for MPEG-2 streams), and the temporal
reference of the picture.

You can display the Main view window without the detail in the rectangles by
selecting Cut Down/Blow up Main View from the Window menu, or by
pressing the F3 function key.

To access a graphical view of an MPEG structure, double-click one of the
rectangles associated with the structure you want to display from the Main view
window. The resulting display is called an interpreted view. Using interpreted
view windows, you can display a representation of the following MPEG-1 and
MPEG-2 video stream structures and perform syntactic analyses on these
structures:

� Sequence structures

� Group of Pictures structures

� Pictures structures

� Slice structures

Like the Main view window, interpreted view windows are interactive. Each
interpreted view displays the values found in different MPEG structures for the
active video stream. Each field is named and represented by a large rectangle;
each value is displayed in a small rectangle just below the large named rectangle.
(See the following illustration of the Sequence view window.)

Interpreted Views
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Double-click a large rectangle to display a description of the field. You can move
the displayed message box anywhere within the view window. To move the
message box, click and drag the title bar. Dismiss the message box by clicking
anywhere outside of it.

Double-click a small rectangle to display an interpretation of the value for that
field. Dismiss the message box by clicking anywhere outside of it.
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Interpreted view windows can also display the position or the length of the field
in the bitstream. When enabled, this information is displayed below the small
rectangles. Select which type of information, if any, you want to display using
the following procedure:

1. Select Interpretation from the Options menu, and then select one of the
following options:

� Position indicates the position in the bitstream of the first bit of the
parameter. Position is relative to the to the first bit in the displayed
syntax.

� Length is the length in bits of the parameter.

2. To disable the display of this information, deselect both options (this is
the default configuration).

When you start a new MPEG Video Stream Analyzer session, the analyzer
uses the configuration used the last time the analyzer was exited.

You can use the Binary and Hexadecimal view windows to view the bitstream of
the video elementary stream for the active MPEG structure. Access the Binary
and Hexadecimal views using the following procedure:

1. Navigate to the interpreted view window for the structure you want to
analyze.

2. Select the Add View button on the Upper toolbar (see page 2–3), and then
select Binary or Hexadecimal from the submenu. Alternatively, you can
select Add View from the Window menu, and then select Binary or
Hexadecimal from the submenu.

The characteristics of the Binary and Hexadecimal view are described in Binary
and Hexadecimal View on page 3–9.

The picture displayed under the Sequence rectangle in the Main view window (if
decoded) corresponds to the first I-picture of the group of pictures. This picture
is decoded using only the DC coefficients of the macroblocks. Double-click the
picture to display the Decoded Picture view window. The resulting picture is
decoded using all of the coefficients.

NOTE. The Decoded Picture view window is a visualization tool, not an analysis
tool.

Binary and Hexadecimal
Views

Decoded Picture View
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You can add multiple view windows to the application window using one of the
following techniques:

� Select the Add View button from the Upper toolbar (see page 2–3), and
then select the type of view window you want displayed from the submenu.

� Select Add View from the Window menu, and then select the type of view
window you want displayed from the submenu.

The views available from the submenus in both cases depend on the active view
window as described in Table 2–4.

Table 2–4: Add view options 

From this view window Select Add View to display

Main view � An additional Main view or
� A Decoded Picture view

Interpreted view � An additional interpreted view or
� A Binary or Hexadecimal view

Binary or Hexadecimal view � An interpreted view of the syntax or
� A Binary or Hexadecimal view

Decoded Picture view � A Main view or
� An additional Decoded Picture view

Adding Views
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Basic Operations
This section describes how to open, save, print, and analyze MPEG video stream
files and how to exit the application.

The MPEG Video Stream Analyzer displays the following video elementary
stream types:

� MPEG-1 and MPEG-2 elementary video stream files

� Video elementary streams extracted from an MPEG transport stream

NOTE. The MPEG Video Stream Analyzer cannot analyze a file containing both
MPEG-1 and MPEG-2 video streams.

Opening elementary video stream files. To open a video stream file, use the
following procedure:

1. Click the Open button on the Upper toolbar (see page 2–3), or select Open
from the File menu.

2. Select the appropriate file from the Open dialog box.

3. From the List files of type drop down selection box, select the type of
document you want to open the file as, and then select OK.

Opening Video Streams
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The following list describes how each of the List files of type options affects
how the elementary stream file is opened:

NOTE. Files opened using the Video Stream option display only those items that
come after the first sequence header in the bitstream. Files opened using either
the GOP and Picture document options display all of the GOPs and Pictures in
the file regardless of whether the file has a sequence header. Consequently, files
opened using one of the latter options may allow you to view GOPs and Pictures
you otherwise could not.

� Video Stream. When a video stream file is opened using this option, the
Main Characteristics and Main view windows are displayed. Only files that
have a sequence header can be opened using this option.

� SEQUENCE documents. When a video stream file is opened using this
option, the Sequence interpreted view window is displayed.

� GOP documents. When a video stream file is opened using this option, the
Group of pictures interpreted view window is displayed.

� PICTURES documents. When a video stream file is opened using this
option, the Pictures interpreted view window is displayed.

If you open a video stream as a Pictures document and the file contains no
sequence header, the MPEG Video Stream Analyzer uses default interpreta-
tion parameters to display the file. In this case, you will see a message
indicating that some of displayed parameters could be false.

Opening video streams extracted from a transport stream. To open and analyze an
elementary stream that is extracted from a transport stream file, use the following
procedure:

1. Confirm that you know the PID of the packets that contain the video stream
of interest. If necessary, examine the transport stream first with the Tektronix
Deferred-Time Analyzer application.

2. Select Open from the File menu.

3. Select the appropriate file from the Open dialog box.

4. Enter the PID of the packets that contain the video stream.

NOTE. You can open the MPEG Video Stream Analyzer with an elementary video
stream directly from the Tektronix Deferred-Time Analyzer. From the Hierarchic
View, right-click the video elementary stream icon and select Video Stream
Analyzer from the submenu.
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Use the following procedure to save all or part of a video stream to a file. (See
Appendix A: Save Video Stream Option Examples for examples of how the
different Save as dialog box options work in different scenarios.)

NOTE. Because you can save video streams only from the Main view window,
only those sequence headers, GOPs, and pictures after the first sequence header
can be saved to a new video stream file.

1. Navigate to the Main view window, and then click the Save as button on the
Upper toolbar (see page 2–3), or select Save As from the File menu.

The displayed dialog box allows you to select which part of the active video
stream you want to save. The default settings are shown in the following
illustration.

2. Choose the portion of the elementary stream you want to save by selecting
one of the following options:

� All the video stream. Use this option to save the entire displayed video
stream; that is, all sequence headers, GOPs, and pictures.

NOTE. For the following options, if a sequence header immediately precedes the
GOP, the sequence header is automatically saved.

� I-Picture. Use this option to save the indicated I-Picture and the GOP
associated with it.

Saving Video Streams
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� From picture. Use this option to save the indicated range of pictures.
The saved portion of the stream begins with the GOP following the
picture indicated in the From picture text box and includes the GOP of
the picture indicated in the to picture text box, with the following two
exceptions:

� If the picture indicated in the From picture text box is the first
picture in any GOP, then the stream is saved beginning with the
GOP of the picture, not the following GOP.

� If the indicated pictures are in the same GOP, then that GOP is
saved.

� From GOP. This option allows you to save the indicated range of
groups of pictures.

� From. This option allows you to save the indicated time segment of the
video stream. Time is indicated in milliseconds. This option uses the
same criteria as the From picture option.

NOTE. All of the text boxes in the Save as dialog box must include a value
greater than 0. Blank text boxes, or text boxes with out of range values are
flagged as errors. If a blank text box, or out of range value is detected, an error
message is displayed indicating the correct range of values. To continue saving
the video stream, you must first enter a valid value in the text box.

3. If you have selected an I-picture, a range of pictures or GOPs, or a time
segment, enter the I-picture number or the appropriate values in the From
and to text boxes.

4. Enter the Repetition Count to specify the number of times the stream
segment is repeated in the new file. All repetitions greater than one are
appended to one another in the new file.

NOTE. Ensure that the first saved GOP is preceded by a sequence header. If you
do not, you will be unable to open a Main view window of the saved stream later.

5. Choose a Sequence Header and/or a Sequence End if appropriate. Choose
Sequence Header if the selected picture(s) or GOP(s) are not immediately
preceded by a sequence header. The new file will use the first sequence
header found in the source stream.

6. When all of the necessary information has been entered, click OK, and a
standard Save as dialog box is displayed.

7. Select an appropriate drive, directory, and file name from the Save as dialog
box, and then click OK.
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NOTE. You cannot save video streams to the Tektronix MPEG Test System Data
Store directory, C:\Carb0.

8. A progress bar is displayed to indicate the status of the operation. Click
cancel to stop the process, or you can press the Esc key on your keyboard.

When the Save as process is finished, a message box is displayed indicating that
the new file has been saved successfully.

You can use the MPEG Video Stream Analyzer to check MPEG encoded video
streams for syntactic and semantic errors.

Syntactic Analysis. Syntactic errors indicate errors in the values of the MPEG
structures.

To perform a syntactic analysis, use the following procedure:

1. Navigate to the interpreted view of the element in the elementary stream that
you want to check.

2. Select Syntactic from the Analysis menu.

3. The analyzer performs a syntactic analysis of the element you have selected
and reports errors in an error message window.

4. Each line in the error message window represents a syntax error. Double-
click an error message and the interpreted view window containing the error
is displayed with the value in error displayed in red.

Analyzing Video Streams
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You can perform a syntactic analysis on all of the structures in the video stream
by navigating to the Main view window, and then performing the analysis. See
Syntactic Analysis on page 3–11 for more information about how the MPEG
Video Stream Analyzer performs syntactic analyses.

Semantic Analysis. Semantic errors indicate errors in the MPEG structure when
compared to the standard.

To perform a semantic analysis, use the following procedure:

1. Navigate to the Main view window.

2. Select Semantic from the Analysis menu.

3. The analyzer performs a semantic analysis of the video stream and reports
errors in an error message window.

4. Each line in the error message window represents a semantic error. Double-
click an error message and the interpreted view window showing the syntax
in error is displayed. Semantic errors are not displayed in red.

Semantic analyses can be performed only from the Main view window. See
Semantic Analysis on page 3–14 for more information about how the MPEG
Video Stream Analyzer performs semantic analyses.

With the MPEG Video Stream Analyzer, you can print any of the view windows
except the Main Characteristics and Decoded Picture view windows. To print the
information displayed in a view window, use the following procedure:

1. Set up the page layout by selecting Printer setup from the File menu, and
then make the appropriate selections for paper size and source, orientation,
and margins from the Page Setup dialog box.

2. Set up the printer connections by selecting the Printer command button, and
then making the appropriate printer and printer properties selections (see
your Windows documentation).

3. Return to the view window you want to print and select Print from the File
menu.

4. The Print dialog box is displayed. Make standard Windows Print selections
and print the contents of the active view window.

Printing Interpreted Views



Operating Basics

MPEG Video Stream Analyzer User Manual 2–19

To quit the MPEG Video Stream Analyzer, select Exit from the File menu.

To close a window without exiting the analyzer application, use one of the
following techniques:

� To close an active view window, select the close button on the active view
window. Alternatively, select Close view from the Window menu.

� To close all windows, select Close all from the Window menu.

Menu Selections
Table 2–5 summarizes each of the menu selections for the MPEG Video Stream
Analyzer.

Table 2–5: Menu selections 

Menu Selection Description

File Open Displays the Open dialog box from which you identify
the existing video stream file you want to view.

Save as Displays the Video Stream Save dialog box from
which you indicate how much of the file you want to
save. After you select OK, a standard Save As dialog
box is displayed.

Print Displays a standard Print dialog box from which you
can print the active view window.

Printer setup Displays the Page Setup dialog box from which you
specify the paper size, orientation, and page
margins. The dialog box also provides access to
printer options.

Exit Quits the MPEG Video Stream Analyzer.

Edit Next Displays the next item in the active view.

Previous Displays the previous item in the active view.

First Displays the first item in the active view.

Last Displays the last item in the active view.

Go to Displays the specified item in the active view.

Number of Items Calculates the number of items in the active view,
and displays the number in the upper portion of the
active view window.

Next error Displays the next item in the active view with a
syntactic error.

Quitting the Application
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Table 2–5: Menu selections (cont.)

Menu DescriptionSelection

Selection Main  Characteristics Displays the Main view window for the video stream
file indicated in the title bar of the view window.

Main  View Displays the Main Characteristics view for the video
stream file indicated in the title bar of the view
window.

Analysis Syntactic Performs a Syntactic analysis on the video stream
file indicated in the title bar of the secondary window.
See page 3–11.

Semantic Performs a Semantic analysis on the video stream
file indicated in the title bar of the secondary window.
See page 3–14.

Automatic Performs the analyses you select using the Options
for automatic analysis dialog box See page 3–17.

Options Cut Down/Blow up 
Main View

Toggles the Main view window between a detailed
view and one that is less detailed. The F3 function
key also toggles between these types of views.

Base Displays the Base dialog box from which you set the
numeric base (decimal or hexadecimal) you want to
use for various interpreted views.

Font Displays the Font dialog box from which you set the
font you want to use for various views.

Directories Displays the Default Directories dialog box. You
select the directories to which the MPEG Video
Stream Analyzer messages and configuration files
are saved.

Automatic Analysis Displays the Options for automatic analysis dialog
box from which you indicate the types of analyses
performed when you select Automatic from the
Analysis menu. You can choose any combination of
the two options. The default is to perform both
syntactic and semantic analyses.

Interpretation Displays the Interpreted view option dialog box from
which you can choose to display either the length or
the position of the structures in the interpreted views.

Read configuration Displays the Read Configuration dialog box from
which you can load an existing configuration file into
the MPEG Video Stream Analyzer.

Save configuration Displays the Save Configuration dialog box from
which you can save the current configuration into a
specified configuration file.

Set default configuration Loads the default configuration file into the MPEG
Video Stream Analyzer.



Operating Basics

MPEG Video Stream Analyzer User Manual 2–21

Table 2–5: Menu selections (cont.)

Menu DescriptionSelection

Window Cascade Displays the open view windows on top of one
another.

Tile Fits the open view windows to the application
window.

Arrange icons Arranges all minimized windows to the bottom of the
application window.

Close view Closes the selected view window.

Close all Closes all of the view windows.

Add view Displays a submenu from which you can choose to
add an identical view of the selected view or a
different view of the displayed information. Same as
the Add View button on the upper toolbar.

List of open view
windows

Selects the active view from the listed view windows
and brings the selected view to the front of the
display. All open views are listed, including any
minimized windows. A checkmark indicates the
current active view.

Help Contents Displays the MPEG Video Stream Analyzer Help
contents from which you can choose or search for a
specific help topic.

Using help Displays the Windows Help contents.

About MPEG Video
Stream Analyzer

Displays version number and copyright information
about the MPEG Video Stream Analyzer.
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Reference

Reference provides detailed information about the MPEG Video Stream
Analyzer. This chapter is organized into the following sections:

� Interpreted Views

� Additional Views

� Analyzing Video Elementary Streams

� Configuration Reference

Commonly performed procedures, view window descriptions, and common
interface elements are described in Operating Basics.

Interpreted Views
The MPEG Video Stream Analyzer uses four interpreted views to display the
elements of MPEG-1 and MPEG-2 encoded video streams:

� Sequence. This view window displays elements described by the video
sequence structures of MPEG-1 and MPEG-2 encoded video streams.

� Group of pictures (GOP). This view window displays elements described
by the GOP structures of MPEG-1 and MPEG-2 encoded video streams.

� Picture. This view window displays elements described by the picture
structures of MPEG-1 and MPEG-2 encoded video streams.

� Slice. This view window displays elements described by the slice structures
of MPEG-1 and MPEG-2 encoded video streams.

Each of the interpreted view windows are interactive and have some common
interface elements. These common elements are described in the next section,
Interpreted View Window Common Elements. The following sections describe
each of the interpreted views in more detail.
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Each interpreted view window uses a series of rectangles to represent the fields
and values associated with specific MPEG video elementary stream structures.
Shaded rectangles are used to highlight more important or critical fields and
values of MPEG elementary streams. The following illustration of the Sequence
view window shows the elements that all interpreted view windows have in
common.

Length/Position
indicator

Large rectangles

Small rectangles

Row of
rectangles

In addition to the common elements for the MPEG Video Stream Analyzer view
windows (see Common View Window Elements on page 2–5), the preceding
illustration shows the following elements common to interpreted view windows:

� Row of rectangles. Each row in an interpreted view window represents a
structure in the displayed element. For instance, the first row of the
preceding illustration represents the sequence_header() structure; the second
row represents the sequence_extension() structure, and the third line
represents the extension_and_user_data() structure.

� Large rectangles. The large rectangles represent specific fields in the
structure of the displayed element. For instance, in the preceding illustration,
the large rectangle, Horizontal size value, represents the
horizontal_size_value field.

Double-click a large rectangle to display a description of the field. You can
move the message box to make it easier to read by clicking and dragging the
title bar of the message box. Dismiss the message box by clicking anywhere
outside of the box.

Interpreted View Window
Common Elements
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� Small rectangles. The small rectangles represent the values encoded in the
bitstream for the fields.

Displayed values can be shown in decimal or hexadecimal base. To toggle
between the two, press the F2 function key. (You can also select Base from
the Options menu, and then make the selection from the dialog box.) Red
values indicate syntax errors.

Double-click a small rectangle to display an interpretation of the value.
Dismiss the message box by clicking anywhere outside of the box.

� Length/Position indicator. Interpreted views can display the position or the
length of the fields. When enabled, this information is displayed below the
small rectangles. You determine which type of information, if any, is
displayed using the following procedure:

1. Select Interpretation from the Options menu, and then select one of the
following options:

� Position indicates the position in the bitstream of the first bit of the
parameter. Position is relative to the to the first bit in the displayed
syntax.

� Length is the length in bits of the parameter.

2. To disable the display of this information, deselect both options (this is
the default configuration).

When you start a new MPEG Video Stream Analyzer session, the analyzer
uses the configuration used the last time the analyzer was exited.

You can use the Edit toolbar to navigate through the displayed items from all of
the interpreted view windows. See Edit Toolbar on page 2–4 for more informa-
tion about the Edit toolbar.

You can also display a Binary or Hexadecimal view window from any inter-
preted view window using one of the following methods:

� Click the Add view button, and then select either Binary or Hexadecimal
from the submenu.

� Select Add view from the Window menu, and then select either Binary or
Hexadecimal from the submenu.
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To access the Sequence interpreted view window, double-click the large
Sequence Header rectangle from the Main view window.

You can also access the Sequence interpreted view window by opening a video
stream as a Sequence documents file type. See Opening Video Streams on
page 2–13.

See Interpreted Views on page 2–9 and Interpreted View Window Common
Elements on page 3–2 for information about interpreted view windows and how
to use the interface elements.

If the video stream was extracted from a transport stream, the PID of the
elementary stream is displayed in the title bar of the view window.

The Sequence interpreted view may display the following structures:

� Sequence Header

� Sequence Extension

� Sequence Display Extension

� Sequence Scalable Extension

� User Data

Sequence View
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Double-clicking the value rectangle (small rectangle) of the quant matrixes
(which can be present in either the sequence header or in the quant matrix
extension) displays the quant matrix.

Double-click the large User data rectangle to display either a binary or hexade-
cimal view of the sequence structure. The value displayed in the small User data
rectangle indicates the number of data bytes.

The GOP interpreted view displays the GOP header structure. To access the GOP
interpreted view window, double-click the large GOP rectangle in the Main view
window.

You can also access the GOP interpreted view window by opening a video
stream as a GOP documents file type. See Opening Video Streams on
page 2–13.

NOTE. If you display the GOP interpreted view window from the Main view
window, only the GOP structures that follow the first sequence header are
displayed. None of the GOPs located before the first sequence header are
displayed. To display all of the GOPs before the first sequence header, open the
file as a GOP documents file type.

See Interpreted Views on page 2–9 and Interpreted View Window Common
Elements on page 3–2 for information about interpreted view windows and how
to use the interface elements.

Group of Pictures (GOP)
View
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If the video stream was extracted from a transport stream, the PID of the
elementary stream is displayed in the title bar of the view window.

To access the Picture interpreted view, double-click the large Picture  rectangle in
the Main view window.

You can also access the Picture interpreted view by opening a video stream as a
Picture documents file type. See Opening Video Elementary Streams on
page 2–13.

NOTE. If you display the Picture interpreted view window from the Main view
window, only the Picture structures that follow the first sequence header are
displayed. None of  the pictures located before the first sequence header are
displayed. To display all of the pictures before the first sequence header, open
the file as a Picture documents file type.

See Interpreted Views on page 2–9 and Interpreted View Window Common
Elements on page 3–2 for information about interpreted view windows and how
to use the interface elements.

Picture View
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If the video stream was extracted from a transport stream, the PID of the
elementary stream is displayed in the title bar of the view window.

The Picture interpreted view may display the following picture structures:

� Picture header

� Picture coding extension

� Quant matrix extension

� Picture display extension

� Copyright extension

� Picture spatial scalable extension

� Picture temporal scalable extension

� Picture data

Double-click the large Picture data rectangle to display the Slice view, which is
described in the next section. The small Picture data rectangle indicates the
number of data bytes for the picture data.
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To display the Slice interpreted view, double-click the large Picture data
rectangle in the Picture interpreted view window.

You can also display the Slice view from the Picture view using one of the
following methods:

� Click the Add View button on the Upper toolbar (see page 2–3), and then
select Slice View from the submenu.

� Select Add View from the Window menu, and then select Slice View from
the submenu.

The look and use of the Slice view is similar to the other interpreted views.
However, the Slice view window provides an additional toolbar that you use to
navigate through the slices of the displayed picture. The current picture is
indicated in the top line of the view window. Table 3–1 describes the Slice
toolbar elements.

Table 3–1: Slice toolbar elements 

Element Name Description
ÁÁÁÁÁÁ
ÁÁÁÁÁÁ
ÁÁÁÁÁÁ

Slice number
ÁÁÁÁÁÁÁÁÁÁÁÁÁÁÁÁ
ÁÁÁÁÁÁÁÁÁÁÁÁÁÁÁÁ
ÁÁÁÁÁÁÁÁÁÁÁÁÁÁÁÁ

Indicates which slice of the current picture is displayed.

ÁÁÁÁÁÁ
ÁÁÁÁÁÁ

First ÁÁÁÁÁÁÁÁÁÁÁÁÁÁÁÁ
ÁÁÁÁÁÁÁÁÁÁÁÁÁÁÁÁ
Displays the first slice of the current picture.

ÁÁÁÁÁÁ
ÁÁÁÁÁÁ
ÁÁÁÁÁÁ

Previous ÁÁÁÁÁÁÁÁÁÁÁÁÁÁÁÁ
ÁÁÁÁÁÁÁÁÁÁÁÁÁÁÁÁ
ÁÁÁÁÁÁÁÁÁÁÁÁÁÁÁÁ

Displays the previous slice of the current picture.

ÁÁÁÁÁÁ
ÁÁÁÁÁÁ

Go to ÁÁÁÁÁÁÁÁÁÁÁÁÁÁÁÁ
ÁÁÁÁÁÁÁÁÁÁÁÁÁÁÁÁ
Displays the slice of the current picture that you indicate.

ÁÁÁÁÁÁ
ÁÁÁÁÁÁ

Next ÁÁÁÁÁÁÁÁÁÁÁÁÁÁÁÁ
ÁÁÁÁÁÁÁÁÁÁÁÁÁÁÁÁ
Displays the next slice of the current picture.

ÁÁÁÁÁÁ
ÁÁÁÁÁÁ
ÁÁÁÁÁÁ

Last
ÁÁÁÁÁÁÁÁÁÁÁÁÁÁÁÁ
ÁÁÁÁÁÁÁÁÁÁÁÁÁÁÁÁ
ÁÁÁÁÁÁÁÁÁÁÁÁÁÁÁÁ

Displays the last slice of the current picture.

ÁÁÁÁÁÁ
ÁÁÁÁÁÁ
ÁÁÁÁÁÁ

Number of
items

ÁÁÁÁÁÁÁÁÁÁÁÁÁÁÁÁ
ÁÁÁÁÁÁÁÁÁÁÁÁÁÁÁÁ
ÁÁÁÁÁÁÁÁÁÁÁÁÁÁÁÁ

Displays the number of slices of the current picture. The total
number of slices is then displayed in the Slice number element.

ÁÁÁÁÁÁ
ÁÁÁÁÁÁ
ÁÁÁÁÁÁ

Next Error ÁÁÁÁÁÁÁÁÁÁÁÁÁÁÁÁ
ÁÁÁÁÁÁÁÁÁÁÁÁÁÁÁÁ
ÁÁÁÁÁÁÁÁÁÁÁÁÁÁÁÁ

Displays the next slice of the current picture that contains at
least one syntactic error.

Slice View
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Additional Views
The MPEG Video Stream Analyzer provides different ways of looking at the
video bitstream using the views described in this section: Binary, Hexadecimal,
and Decoded Picture views. The interactive characteristics of these view
windows are limited and are described in the following sections.

Binary and Hexadecimal views display the bitstream for the structures displayed
when you accessed the Binary or Hexadecimal view.

NOTE. The Binary and Hexadecimal views accessed from the Picture and the
Slice views are identical. Also, the Hexadecimal view of the sequence structure
displays the same information that is displayed when you double-click the large
User data rectangle in the Sequence view window.

To display the Binary and Hexadecimal views for a specific video elementary
stream structure, use the following procedure:

1. Navigate to the interpreted view window for the structure you want to
display.

2. Select the Add View icon on the Upper toolbar (see page 2–3), and then
select Binary or Hexadecimal from the submenu. (Alternatively, select Add
View from the Window menu, and then select Binary or Hexadecimal from
the submenu.)

The information displayed is the bitstream of the item indicated in the top line of
the view window. The following illustration shows the bitstream of the third
item out of 750 in binary format.

Binary and Hexadecimal
View
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The analysis functions of the MPEG Video Stream Analyzer (see Analyzing
Video Elementary Streams beginning on page 3–11) and the Edit toolbar are
available from both the Binary and Hexadecimal views. Only syntactic analyses
can be performed from the Binary or Hexadecimal views, and the Next error
button (and the Next error menu selection) searches for and displays only
syntactic errors.

The small I-picture displayed in the Main view is decoded using only the DC
coefficients. You can display the picture with all of the coefficients decoded
using one of the following methods:

� From the Main view, double-click the small I-picture.

� From the Main view, select Add View, and then select Decoded Picture
View from the submenu.

� From the Main view, select the Add View button on the Upper toolbar (see
page 2–3), and then select Decoded Picture View from the submenu.

NOTE. The decoded I-picture is independent from all analyses performed by the
MPEG Video Stream Analyzer. It is not a way to analyze the stream, but provides
you with visual feedback about the video stream. If a problem occurs during the
decoding process, the I-picture is not decoded.

Decoded Picture View
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Analyzing Video Elementary Streams
The MPEG Video Stream Analyzer can check for both syntactic and semantic
errors as described in this section.

Syntactic analysis checks the validity of the values for each structure indicated in
Table 3–2 against the syntax described in the appropriate paragraph from the
standard.

Table 3–2: Syntactic analysis tests 

Interpreted View Structure ISO/IEC 13818-2 paragraph

ÁÁÁÁÁÁ
ÁÁÁÁÁÁ

Sequence ÁÁÁÁÁÁÁÁÁÁ
ÁÁÁÁÁÁÁÁÁÁ

Sequence header ÁÁÁÁÁÁÁÁÁÁ
ÁÁÁÁÁÁÁÁÁÁ

6.2.2.1

ÁÁÁÁÁÁ
ÁÁÁÁÁÁ

ÁÁÁÁÁÁÁÁÁÁ
ÁÁÁÁÁÁÁÁÁÁ

Sequence extension ÁÁÁÁÁÁÁÁÁÁ
ÁÁÁÁÁÁÁÁÁÁ

6.2.2.3

ÁÁÁÁÁÁ
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Sequence display extension ÁÁÁÁÁÁÁÁÁÁ
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6.2.2.4
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Sequence scalable extension ÁÁÁÁÁÁÁÁÁÁ
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6.2.2.5
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Group of PicturesÁÁÁÁÁÁÁÁÁÁ
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Group of pictures header ÁÁÁÁÁÁÁÁÁÁ
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6.2.2.6
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Picture/Slice ÁÁÁÁÁÁÁÁÁÁ
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Picture header ÁÁÁÁÁÁÁÁÁÁ
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6.2.3
ÁÁÁÁÁÁ
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Picture coding extension ÁÁÁÁÁÁÁÁÁÁ
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6.2.3.1
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Quant matrix extension ÁÁÁÁÁÁÁÁÁÁ
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6.2.3.2
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Picture display extension ÁÁÁÁÁÁÁÁÁÁ
ÁÁÁÁÁÁÁÁÁÁ

6.2.3.3
ÁÁÁÁÁÁ
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Picture temporal scalable extension
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6.2.3.4
ÁÁÁÁÁÁ
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Picture spatial scalable extension
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6.2.3.5
ÁÁÁÁÁÁ
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ÁÁÁÁÁÁÁÁÁÁ
ÁÁÁÁÁÁÁÁÁÁCopyright extension

ÁÁÁÁÁÁÁÁÁÁ
ÁÁÁÁÁÁÁÁÁÁ6.2.3.6

Picture data 6.2.3.7ÁÁÁÁÁÁ
ÁÁÁÁÁÁ

ÁÁÁÁÁÁÁÁÁÁ
ÁÁÁÁÁÁÁÁÁÁSlice

ÁÁÁÁÁÁÁÁÁÁ
ÁÁÁÁÁÁÁÁÁÁ6.2.4

The MPEG Video Stream Analyzer does not perform a syntactic analysis on the
following MPEG-2 structures: 

� Macroblock (6.2.5)

� Macroblock modes (6.2.5.1)

� Motion vectors (6.2.5.2)

� Motion vector (6.2.5.2.1)

� Coded block pattern (6.2.5.3)

� Block (6.2.6)

Syntactic Analysis
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You can perform syntactic analyses on a specific video stream structure, or on
the entire video stream, using the following procedure:

1. Display the interpreted view window of the syntax you want to check. (If
you want to check all of the sequence, GOP, and picture structures, perform
the syntax analyses from the Main view window.)

2. Select Syntactic from the Analysis menu. The view window changes and
looks similar to the following illustration. Press the Esc key to stop the
process.

3. If the analysis finds errors in the video stream syntax, the following message
box is displayed. Each line represents an error at the location indicated
(structure, item, and field).
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4. To view the error, double-click a message line. The interpreted view
containing the field in error is displayed with the value in error shown in red.

You can perform syntactic analyses on multiple structures or multiple elementary
streams at the same time.

NOTE. If you perform a syntactic analysis on a stream that you opened as a
Video Stream file type, the syntax analysis begins on the structures located after
the first sequence header. If you perform a syntactic analysis on a stream you
opened as a Sequence, GOP, or Pictures documents file type, the analyses are
performed on all of the items for the video stream.
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Semantic analyses checks the structure of the MPEG video stream, rather than
the values of the fields. Semantic analyses can be performed only when the Main
view is the active view window.

Table 3–3 describes the analyses performed when you conduct a semantic
analysis of the video stream. The paragraph numbers indicate the paragraph or
paragraphs of the standard upon which the tests are based.

Table 3–3: Semantic analysis tests 

Structure
ISO/IEC 13818-2
paragraph(s) Description

ÁÁÁÁÁ
ÁÁÁÁÁ
ÁÁÁÁÁ
ÁÁÁÁÁ
ÁÁÁÁÁ
ÁÁÁÁÁ
ÁÁÁÁÁ
ÁÁÁÁÁ

Sequence
header

ÁÁÁÁÁÁ
ÁÁÁÁÁÁ
ÁÁÁÁÁÁ
ÁÁÁÁÁÁ
ÁÁÁÁÁÁ
ÁÁÁÁÁÁ
ÁÁÁÁÁÁ
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6.1.1.6 ÁÁÁÁÁÁÁÁÁÁÁÁÁÁÁ
ÁÁÁÁÁÁÁÁÁÁÁÁÁÁÁ
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ÁÁÁÁÁÁÁÁÁÁÁÁÁÁÁ

If there are repeated sequence headers, all of the data
elements shall have the same values as in the first
sequence header (with the exception of  those defining
the quantization matrixes: load_intra_quantiser_matrix,
load_non_intra_quantiser_matrix, and optionally
intra_quantiser_matrix and non_intra_quantiser_matrix).

In the case that an interlaced frame is coded as two
separate field pictures, a repeat sequence header shall
not precede the second of these two field pictures.

ÁÁÁÁÁ
ÁÁÁÁÁ
ÁÁÁÁÁ
ÁÁÁÁÁ
ÁÁÁÁÁ
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Sequence
extension
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6.3.1

 6.1.1.6
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Sequence_extension() shall only occur immediately
following a sequence_header().

If the first sequence_header() of a sequence is followed
by a sequence_extension(), then all subsequent
occurrences of sequence_header() shall also be
immediately followed by a sequence_extension().

All of the data elements in the sequence_extension() that
follow a repeated sequence_header() shall have the same
values as in the first sequence_extension().

Sequence_extension() shall not immediately precede a
sequence_end_code.
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Sequence
display 
extension
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6.1.1.6 ÁÁÁÁÁÁÁÁÁÁÁÁÁÁÁ
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If a sequence_display_extension() occurs after the first
sequence_header(), then all subsequent sequence
headers shall be followed by sequence_display_exten-
sion().

All data elements of a repeated
sequence_display_extension() must be the same as in the
first sequence_display_extension().

Conversely, if no sequence_display_extension() occurs
between the first sequence_header() and the first
picture_header(), then sequence_display_extension()
shall not occur in the bitstream.

Semantic Analysis
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Table 3–3: Semantic analysis tests (cont.)

Structure Description
ISO/IEC 13818-2
paragraph(s)
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Sequence 
scalable 
extension
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If a sequence_scalable_extension() occurs after the first
sequence_header(), then all subsequent sequence
headers shall be followed by
sequence_scalable_extension().

All data elements of a repeated
sequence_scalable_extension must be the same as the
first sequence_scalable_extension().

Conversely, if no sequence_scalable_extension() occurs
between the first sequence_header() and the first
picture_header(), then sequence_scalable_extension()
shall not occur in the bitstream.
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Picture header
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6.3.1
6.1.1.11
6.3.9
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The first coded frame following a
group_of_pictures_header() shall be a coded I-frame.

The first coded frame after a sequence header shall not
be a B-frame.

When a frame is coded as two fields, then temporal_refer-
ence in the picture header of both fields is the same.
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Picture coding
extension
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6.3.1
6.3.10
6.1.1.4.1
6.3.5
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picture_coding_extension() shall only occur immediately
following a picture_header().

If sequence_extension() occurs in the bitstream, then
each picture_header() shall be followed immediately by a
picture_coding_extension().

When a frame is encoded in the form of two field pictures,
both fields must be of the same picture_coding_type,
except when the first encoded field is an I-picture.

When a frame is encoded in the form of two field pictures,
if the first encoded field is an I-picture, the second may be
either an I-picture or a P-picture.

The first encoded field of a frame may be a top field or a
bottom field, and the next field must be of opposite parity.

If progressive_sequence is set to 1, the coded video
sequence shall contain only progressive frames pictures.

ÁÁÁÁÁ
ÁÁÁÁÁ
ÁÁÁÁÁ

Picture display
extension
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6.3.12 ÁÁÁÁÁÁÁÁÁÁÁÁÁÁÁ
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A picture_display_extension() shall not occur unless a
sequence_display_extension() followed the previous
sequence_header().
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Use the following procedure to perform a semantic analysis of the video stream:

1. Navigate to the Main view window for the video stream you want to analyze.

2. Select Semantic from the Analysis menu.  The view window will change
and look similar to the following illustration. Press the Esc key to stop the
process.

3. If the analysis finds semantic errors, a message box similar to the following
illustration is displayed.

4. To view an error, double-click a message line. The interpreted view
displaying the structure in error is displayed as shown in the following
illustration. For semantic analyses, the errors are not indicated in red.
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You can perform semantic analyses on multiple elementary streams at once.

When you select Automatic from the Analysis menu, the MPEG Video Stream
Analyzer can perform any combination of Syntactic and Semantic analyses.
Indicate which analyses you want performed by selecting or deselecting them in
the Options for automatic analysis dialog box.

To specify how the analyzer performs automatic analyses, use the following
procedure:

1. Select Automatic Analysis from the Options menu.

2. Select any combination of the two options from the dialog box, and then
click OK.

To perform an automatic analysis, use the following procedure:

1. Navigate to the Main view window for the stream you want to analyze.

2. Select Automatic from the Analysis menu.

3. The message box shown in the following illustration is displayed while the
type(s) of analyses that you selected in the previous procedure are
performed.

Automatic Analysis
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The title bar indicates the file on which the analyses are being performed.
The sequence headers and GOPs being analyzed are indicated in the bottom
portion of the Automatic Analysis window. Select the command button at
the bottom of the window to stop the analyses.

4. When the analyses are complete, the results column indicates whether any
syntactic and/or semantic errors were found.

5. Double-click a red Error to display an error message window.

6. To view an error, double-click a message line in the error message window.
The interpreted view containing the field in error is displayed. If the error is
a syntax error, the value in error is shown in red. Semantic errors are not
shown in red.
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Configuration Reference
Using the selections from the Options menu, you can configure how the current
MPEG Video Stream Analyzer session displays information, and you can save
and load configuration files.

You can change the numerical base displayed in the small rectangles of the
interpreted view using one of the following methods:

� Select Base from the Options menu, and then select Decimal or Hexade-
cimal.

� Press the F2 function key to toggle the numerical base settings.

NOTE. Even though you can display information in either decimal or hexade-
cimal, you can enter values only in decimal base.

When you start a new MPEG Video Stream Analyzer session, the analyzer uses
the base displayed the last time you exited the application.

You can change the font displayed in the view windows using the Font dialog
box. To display the Font dialog box, select Font from the Options menu. Some
view windows use a fixed font and are not affected by font choices.

When you start a new MPEG Audio Stream Analyzer session, the analyzer uses
the font displayed the last time you exited the application.

You can display the length or the position of a parameter in the bitstream. When
enabled, this information is displayed below the small rectangles in interpreted
view windows. You determine which type of information, if any, is displayed
using the following procedure:

1. Select Interpretation from the Options menu, and then select one of the
following options:

� Position indicates the position in the bitstream of the first bit of the
parameter. Position is relative to the to the first bit in the displayed
syntax.

� Length is the length in bits of the parameter.

2. To disable the display of this information, deselect both options (this is
the default configuration).

When you start a new MPEG Video Stream Analyzer session, the analyzer
uses the configuration used the last time the analyzer was exited.

Numerical Base

Font

Interpretation
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The Default Directories dialog box accessed by this menu selection allows you
to indicate what directory the MPEG Video Stream Analyzer should default to
when writing and loading message and configuration files.

Include the full path to each directory.

There are three Options menu selections you can use to save and load configura-
tion files. The configuration files determine the following states for the current
analyzer session (default settings are indicated in parentheses):

� Base (Decimal)

� Font (9pt, Times New Roman)

� Interpretation (No interpretation options selected)

� Main view type (Standard view)

� Default message and configuration directories (path to your
MTS300\VIDEO directory)

� Type of automatic analysis (Syntactic and Semantic analyses performed)

The analyzer uses the configuration that was current when you last exited the
application.

Directories

Configuration Files
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Read Configuration. This menu selection displays a dialog from which you can
load a previously saved configuration file (an .acf file) into the current analyzer
session. Use standard Windows NT Open dialog box methods to open and load a
configuration file.

Save Configuration. This menu selection displays a dialog box from which you
can save the current configuration settings to a new configuration file (an .acf
file). Use standard Windows NT Save as dialog box methods to save a new
configuration file.

Set Default Configuration. This menu selection displays a dialog box from which
you can change the current configuration selections to the default settings
described on page 3–20.
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Appendix A: Save Video Stream Option Examples

The following scenarios will help explain how parts of a video stream are saved
using the Save Video Stream dialog box options. For each of the examples in
this section, refer to the following description of a hypothetical video stream:

Sequence headers (5) Group of pictures (5) Pictures (84)
ÁÁÁÁÁÁÁÁÁ
ÁÁÁÁÁÁÁÁÁ

SH1 ÁÁÁÁÁÁÁÁ
ÁÁÁÁÁÁÁÁ

GOP1 ÁÁÁÁÁÁÁÁÁ
ÁÁÁÁÁÁÁÁÁ

P1 through P12
ÁÁÁÁÁÁÁÁÁ
ÁÁÁÁÁÁÁÁÁ

SH2 ÁÁÁÁÁÁÁÁ
ÁÁÁÁÁÁÁÁ

GOP2 ÁÁÁÁÁÁÁÁÁ
ÁÁÁÁÁÁÁÁÁ

P13 through P24
ÁÁÁÁÁÁÁÁÁ
ÁÁÁÁÁÁÁÁÁ

SH3 ÁÁÁÁÁÁÁÁ
ÁÁÁÁÁÁÁÁ

ÁÁÁÁÁÁÁÁÁ
ÁÁÁÁÁÁÁÁÁ

P25 through P36
ÁÁÁÁÁÁÁÁÁ
ÁÁÁÁÁÁÁÁÁ

SH4
ÁÁÁÁÁÁÁÁ
ÁÁÁÁÁÁÁÁ

ÁÁÁÁÁÁÁÁÁ
ÁÁÁÁÁÁÁÁÁ

P37 through P48
ÁÁÁÁÁÁÁÁÁ
ÁÁÁÁÁÁÁÁÁ
ÁÁÁÁÁÁÁÁÁ

ÁÁÁÁÁÁÁÁ
ÁÁÁÁÁÁÁÁ
ÁÁÁÁÁÁÁÁ

GOP3
ÁÁÁÁÁÁÁÁÁ
ÁÁÁÁÁÁÁÁÁ
ÁÁÁÁÁÁÁÁÁ

P49 through P60ÁÁÁÁÁÁÁÁÁ
ÁÁÁÁÁÁÁÁÁ
ÁÁÁÁÁÁÁÁÁ

ÁÁÁÁÁÁÁÁ
ÁÁÁÁÁÁÁÁ
ÁÁÁÁÁÁÁÁ

GOP4
ÁÁÁÁÁÁÁÁÁ
ÁÁÁÁÁÁÁÁÁ
ÁÁÁÁÁÁÁÁÁ

P61 through P72

ÁÁÁÁÁÁÁÁÁ
ÁÁÁÁÁÁÁÁÁ

SH5 ÁÁÁÁÁÁÁÁ
ÁÁÁÁÁÁÁÁ

GOP5 ÁÁÁÁÁÁÁÁÁ
ÁÁÁÁÁÁÁÁÁ

P73 through P84

Keep in mind the rules used by the MPEG Video Stream Analyzer when
determining which parts of the video stream to save:

� Video stream files can be saved only from the Main view window.

� Only video streams with at least one sequence header can be saved.

� Only those sequence headers, GOPs, and pictures after the first sequence
header can be saved to a new video elementary stream file.

� If a sequence header immediately precedes a GOP that is to be saved, the
sequence header is automatically saved.

� The saved portion of the stream begins with the GOP following the picture
you indicate in the From picture text box and includes the GOP of the
picture you indicate in the to picture text box, with the following two
exceptions:

� If the picture indicated in the From picture text box is the first picture in
any GOP, then the stream is saved beginning with the GOP of the
picture, not the following GOP.

� If the indicated pictures are in the same GOP, then that GOP is saved.
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In the Save as dialog box, you select From GOP 2 to GOP 2. The saved portion
of the stream will then include the following elements:

Sequence headers Group of pictures Pictures

ÁÁÁÁÁÁÁÁÁ
ÁÁÁÁÁÁÁÁÁ

SH2 ÁÁÁÁÁÁÁÁÁ
ÁÁÁÁÁÁÁÁÁ

GOP2 ÁÁÁÁÁÁÁÁ
ÁÁÁÁÁÁÁÁ

P13 through P24

ÁÁÁÁÁÁÁÁÁ
ÁÁÁÁÁÁÁÁÁ

SH3 ÁÁÁÁÁÁÁÁÁ
ÁÁÁÁÁÁÁÁÁ

ÁÁÁÁÁÁÁÁ
ÁÁÁÁÁÁÁÁ

P25 through P36

ÁÁÁÁÁÁÁÁÁ
ÁÁÁÁÁÁÁÁÁ

SH4 ÁÁÁÁÁÁÁÁÁ
ÁÁÁÁÁÁÁÁÁ

ÁÁÁÁÁÁÁÁ
ÁÁÁÁÁÁÁÁ

P37 through P48

In the Save as dialog box, you select From GOP 2 to GOP 3. The saved portion
of the stream will then include the following elements:

Sequence headers Group of pictures Pictures

ÁÁÁÁÁÁÁÁÁ
ÁÁÁÁÁÁÁÁÁ

SH2 ÁÁÁÁÁÁÁÁÁ
ÁÁÁÁÁÁÁÁÁ

GOP2 ÁÁÁÁÁÁÁÁ
ÁÁÁÁÁÁÁÁ

P13 through P24

ÁÁÁÁÁÁÁÁÁ
ÁÁÁÁÁÁÁÁÁ

SH3 ÁÁÁÁÁÁÁÁÁ
ÁÁÁÁÁÁÁÁÁ

ÁÁÁÁÁÁÁÁ
ÁÁÁÁÁÁÁÁ

P25 through P36

ÁÁÁÁÁÁÁÁÁ
ÁÁÁÁÁÁÁÁÁ

SH4 ÁÁÁÁÁÁÁÁÁ
ÁÁÁÁÁÁÁÁÁ

ÁÁÁÁÁÁÁÁ
ÁÁÁÁÁÁÁÁ

P37 through P48
ÁÁÁÁÁÁÁÁÁ
ÁÁÁÁÁÁÁÁÁ

ÁÁÁÁÁÁÁÁÁ
ÁÁÁÁÁÁÁÁÁ

GOP3 ÁÁÁÁÁÁÁÁ
ÁÁÁÁÁÁÁÁ

P49 through P60

In the Save as dialog box, you select From GOP 3 to GOP 4. The saved portion
of the stream will then include the following elements:

Sequence headers Group of pictures Pictures

ÁÁÁÁÁÁÁÁÁ
ÁÁÁÁÁÁÁÁÁ

ÁÁÁÁÁÁÁÁÁ
ÁÁÁÁÁÁÁÁÁ

GOP3 ÁÁÁÁÁÁÁÁ
ÁÁÁÁÁÁÁÁ

P49 through P60

ÁÁÁÁÁÁÁÁÁ
ÁÁÁÁÁÁÁÁÁ

ÁÁÁÁÁÁÁÁÁ
ÁÁÁÁÁÁÁÁÁ

GOP4 ÁÁÁÁÁÁÁÁ
ÁÁÁÁÁÁÁÁ

P61 through P72

In the Save as dialog box, you select From picture 30 to picture 70. The saved
portion of the stream will then include the following elements:

Sequence headers Group of pictures Pictures

ÁÁÁÁÁÁÁÁÁ
ÁÁÁÁÁÁÁÁÁ

ÁÁÁÁÁÁÁÁÁ
ÁÁÁÁÁÁÁÁÁ

GOP3 ÁÁÁÁÁÁÁÁ
ÁÁÁÁÁÁÁÁ

P49 through P60

ÁÁÁÁÁÁÁÁÁ
ÁÁÁÁÁÁÁÁÁ

ÁÁÁÁÁÁÁÁÁ
ÁÁÁÁÁÁÁÁÁ

GOP4 ÁÁÁÁÁÁÁÁ
ÁÁÁÁÁÁÁÁ

P61 through P72

P30 belongs to GOP2, but it is not the first picture of the GOP. Therefore, the
analyzer begins saving with GOP3.

Because P70 is part of GOP4, the analyzer saves all of GOP4.

Scenario A

Scenario B

Scenario C

Scenario D
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In the Save as dialog box, you select From picture 13 to picture 70. The saved
portion of the stream will then include the following elements:

Sequence headers Group of pictures Pictures

ÁÁÁÁÁÁÁÁÁ
ÁÁÁÁÁÁÁÁÁ

SH2 ÁÁÁÁÁÁÁÁ
ÁÁÁÁÁÁÁÁ

GOP2 ÁÁÁÁÁÁÁÁÁ
ÁÁÁÁÁÁÁÁÁ

P13 through P24

ÁÁÁÁÁÁÁÁÁ
ÁÁÁÁÁÁÁÁÁ

SH3 ÁÁÁÁÁÁÁÁ
ÁÁÁÁÁÁÁÁ

ÁÁÁÁÁÁÁÁÁ
ÁÁÁÁÁÁÁÁÁ

P25 through P36

ÁÁÁÁÁÁÁÁÁ
ÁÁÁÁÁÁÁÁÁ

SH4 ÁÁÁÁÁÁÁÁ
ÁÁÁÁÁÁÁÁ

ÁÁÁÁÁÁÁÁÁ
ÁÁÁÁÁÁÁÁÁ

P37 through P48

ÁÁÁÁÁÁÁÁÁ
ÁÁÁÁÁÁÁÁÁ

ÁÁÁÁÁÁÁÁ
ÁÁÁÁÁÁÁÁ

GOP3 ÁÁÁÁÁÁÁÁÁ
ÁÁÁÁÁÁÁÁÁ

P49 through P60
ÁÁÁÁÁÁÁÁÁ
ÁÁÁÁÁÁÁÁÁ

ÁÁÁÁÁÁÁÁ
ÁÁÁÁÁÁÁÁ

GOP4 ÁÁÁÁÁÁÁÁÁ
ÁÁÁÁÁÁÁÁÁ

P61 through P72

P13 is the first picture of the GOP2, so the analyzer begins saving with GOP2.
As in the previous example, the analyzer saves all of GOP4.

In the Save as dialog box, you select From picture 50 to picture 57. The saved
portion of the stream will then include the following elements:

Sequence headers Group of pictures Pictures

ÁÁÁÁÁÁÁÁÁ
ÁÁÁÁÁÁÁÁÁ

ÁÁÁÁÁÁÁÁ
ÁÁÁÁÁÁÁÁ

GOP3 ÁÁÁÁÁÁÁÁÁ
ÁÁÁÁÁÁÁÁÁ

P49 through P60

P50 and P57 belong to the same GOP, so the entire GOP (GOP 3) is saved.

Scenario E

Scenario F
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Index
A
About the MPEG Video Stream Analyzer, 1–1
Add view

menu selection, 2–21
options, 2–12

Address, Tektronix, vi
Analyzer views, 2–7
Analyzing video streams, overview, 2–17
Application window, 2–2
Arrange icons, menu selection, 2–21
Automatic analysis

menu selection, 2–20
procedure, 3–17
set up, 2–20

B
Base

menu selection, 2–20
procedure for changing, 3–19

Binary view
displaying, 3–9
overview, 2–11

Bit stream values, interpreting, 3–3
Buttons

edit toolbar, 2–4
slice toolbar, 3–8
upper toolbar, 2–3

C
Cascade, menu selection, 2–21
Change numerical base, 3–19
Close all, menu selection, 2–21
Close view, menu selection, 2–21
Colored rectangles, 3–2
Common view window elements, 2–5
Configuration, read, save, and set default, 3–20
Contacting Tektronix, vi
Contents, menu selection, 2–21
Cut Down/Blow up Main View

F3 function key accelerator, 2–9
menu selection, 2–20

D
Decimal and Hexadecimal base, 3–19
Decoded picture view, 2–11, 3–10
Default configuration file, 3–20
Deferred-Time Analyzer, opening video elementary

streams using, 2–14
Description of common window elements, 2–5
Directories, Option menu selection, 3–20
Displaying items using the Edit toolbar, 2–4
Displaying MPEG descriptions, 3–2

E
Edit toolbar, 2–4
Elementary video streams

analyzing, 2–17
opening, 2–13
printing, 2–18
saving, 2–15

Examples showing how to save video streams, A–1
Exit, menu selection, 2–19
Exiting the application, 2–19

F
First, menu selection, 2–19
First time operation, 1–2
first time operation, v
Font

menu selection, 2–20
setting, 3–19

Functional overview, 2–2

G
Go to, menu selection, 2–19
GOP document, opening a file as, 2–14
Gray rectangles, 3–2
Group of pictures (GOP) view, 3–5
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H
Hardware, installation, v
Hexadecimal and Decimal base, 3–19
Hexadecimal view

displaying, 3–9
overview, 2–11

I
I picture, 2–11

decoding, 3–10
Icons

edit toolbar, 2–4
upper toolbar, 2–3
Video Stream Analyzer, 2–1

Installation, hardware, v
Interpretation, menu selection, 2–20
Interpreted views, 2–9, 3–1

common window elements, 3–2
Group of Pictures (GOP) view, 3–5
Picture view, 3–6
printing, 2–18
Sequence view, 3–4
Slice view, 3–8

Interpreting bit stream values, 3–3
Item indicator, 2–6

L
Last, menu selection, 2–19
Length/Position indicator, 3–3

interpreted views, 2–11
setting, 3–19

Limitations, 1–2
List files of type, open dialog box selection, 2–14
List of open view windows, menu selections, 2–21
Load default configuration, 3–21
Lower toolbar, 2–4

M
Main characteristics, menu selection, 2–20
Main Characteristics view, 2–7
Main view, 2–8

detailed and less detailed option, 2–20
menu selection, 2–20

Main view elements, 2–9
Menu bar, 2–3
Menu Selections

Analysis menu, 2–20
Edit menu, 2–19
File menu, 2–19
Help menu, 2–21
Options menu, 2–20
Selection menu, 2–20
Window menu, 2–21

MPEG descriptions, displaying, 3–2
MPEG elements analyzed

during a semantic analysis, 3–14
during a syntactic analysis, 3–11

MPEG elements displayed
in the GOP view, 3–5
in the Picture and Slice views, 3–7
in the Sequence view, 3–4

MPEG-2 elements not analyzed, 3–11

N
Next, menu selection, 2–19
Next error, menu selection, 2–19
Number of items, 2–6

menu selection, 2–19
Numerical base, procedure for changing, 3–19

O
Open

from a transport stream, 2–14
menu selection, 2–19
using the Deferred-Time Analyzer, 2–14
video stream files, 2–13

Options menu
Automatic analysis selection, 3–17
Base selection, 3–19
Configuration selections, 3–20
Directories selection, 3–20
Font selection, 3–19
length or position indicator, 3–19
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P
Page setup, printer setup, 2–19
Phone number, Tektronix, vi
Picture view, 3–6
Pictures document, opening a file as, 2–14
Position/Length indicator, 3–3

interpreted views, 2–11
setting, 3–19

Previous, menu selection, 2–19
Print

menu selection, 2–19
procedure, 2–18

Print setup, menu selection, 2–19
Product description, 1–1
Product support, contact information, vi

Q
Quant matrix, displaying, 3–5
Quitting the application, 2–19

R
Read configuration, 3–21

menu selection, 2–20
Rectangles

in interpreted view windows, 2–10, 3–2
in Main view window, 2–9
shaded, 3–2

S
Save as, menu selection, 2–19
Save as examples, A–1
Save configuration, 3–21

menu selection, 2–20
Saving video streams

examples, A–1
procedures, 2–15

Semantic analysis
menu selection, 2–20
MPEG elements checked during, 3–14
overview, 2–18
procedure, 3–14

Sequence document, opening a file as, 2–14
Sequence view, 3–4
Service information, vi
Service support, contact information, vi
Set default configuration, 3–21

menu selection, 2–20
Setup, hardware, v
Shaded rectangles, 3–2
Slice toolbar, 3–8
Slice view, 3–8
Software version, v
Specifications, v
Starting the application, 2–1
Status bar, 2–4
Syntactic analysis

menu selection, 2–20
MPEG elements checked during, 3–11
overview, 2–17
procedure, 3–11

T
Tektronix MPEG Test System, 1–2
Tile, menu selection, 2–21
Title bar, 2–2
Toolbar

edit, 2–4
slice, 3–8
upper, 2–3
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U
Upper toolbar, 2–3
URL, Tektronix, vi

V
Version, software, v
Video streams

analyzing, 2–17
opening, 2–13
opening a file as, 2–14
printing, 2–18
saving, 2–15

View type, 2–6
View windows, 2–7

description, 2–5
types, 1–1

Views
adding, 2–12
Binary and Hexadecimal, 2–11, 3–9
Decoded picture, 2–11, 3–10
Group of pictures (GOP), 3–5
Interpreted views, 2–9
Less detailed Main view, 2–9
Main, 2–8
Main characteristics, 2–7
Picture, 3–6
Sequence, 3–4
Slice, 3–8

W
Web site address, Tektronix, vi
Window, application, 2–2
Window elements, 2–5
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